【原创】同意加机器人好友 同意拉机器人入群(含源代码)

admin 3月前 182

学习内容简介

本教程主要实现:

学习编写 同意别人加机器人好友和 同意别人拉机器人入群功能

学习的sdk有如下两个:

Api_HandleFriendEvent

Api_HandleGroupEvent

源代码免费下载

联系我们

如果你有机器人开发问题或有需求不会开发,可与我们进行联系 QQ机器人开发交流群

声明

本教程非官方教程,为作者学习易语言过程的知识总结,将主要内容整理、汇总后,形成本教程。

致力于进行技术交流,帮助新人快速入门,少走弯路。

请在遵守中华人民共和国法律、腾讯相关规定和框架相关说明下进行使用

如您使用本技术,进行包括但不限于如下行为,软件作者并不知情,不承担任何法律风险 1.违法行为 2.违法腾讯规定 3.违法框架规定

教程内容

插件窗口设置

如下所示:

主要配置是否开启功能开关,和机器人主人配置,方便在群里发送指令 开启和关闭功能

主人功能实现

在插件窗口上配置,主人QQ,然后在群里或私聊机器人发送指令,即可开启 同意加机器人好友 或者 同意拉机器人入群 功能

首先找到消息处理函数 X_Event 这个是框架调用插件传递消息的入口函数,看参数 X__消息类型 来区分不同类型的消息 代码如下

.版本 2

' IRC_消息类型 消息类型
' IRC_触发对象_主动 发言用户
' IRC_消息内容 发送内容
.如果真 (IRC_消息类型 = #IRC_群)

    .如果真 (寻找文本 (窗口2.基本_编辑框_主人列表.内容, IRC_触发对象_主动, , 假) > -1)
        ' 发送内容是 开启拉我入群 表示允许拉我入群
        .判断开始 (IRC_消息内容 = “开启拉我入群”)
            窗口2.基本_选择框_拉我入群.选中 = 真

            ' 关闭 拉我入群功能
        .判断 (IRC_消息内容 = “关闭拉我入群”)
            窗口2.基本_选择框_拉我入群.选中 = 假

            ' 开启  加我好友 功能
        .判断 (IRC_消息内容 = “开启加我好友”)
            窗口2.基本_选择框_加好友.选中 = 真
            ' 关闭  加我好友 功能
        .判断 (IRC_消息内容 = “关闭加我好友”)
            窗口2.基本_选择框_加好友.选中 = 假

        .默认

        .判断结束

在群里,机器人主人发送指令 即可控制是否开启对应功能

但如果插件窗口没有打开 将导致异常,所以使用前 需要判断窗体是否已经打开 加一段判断代码即可 是否已创建 (窗口2) 最终代码:

允许加机器人好友

首先知道,别人加机器人好友时 消息类型为 #IRC_某人请求加为好友

判断是否开启了允许加好友功能 允许则调用Api_HandleFriendEvent 进行处理 同意加好友

.版本 2

' 别人请求加机器人好友
.如果真 (IRC_消息类型 = #IRC_某人请求加为好友)
    .如果真 (是否已创建 (窗口2))
        ' 是否允许 加机器人好友
        .如果真 (窗口2.基本_选择框_加好友.选中)
            Api_HandleFriendEvent (IRC_机器人QQ, IRC_触发对象_主动, #IRC_请求处理_同意, “”)
        .如果真结束

允许拉机器人入群

代码及说明如下

.版本 2

' 别人拉机器人入群 消息是214

.如果真 (IRC_消息类型 = 214)
    ' 判断窗口是否打开
    .如果真 (是否已创建 (窗口2))
        ' 判断是否允许
        .如果真 (窗口2.基本_选择框_拉我入群.选中)
            ' 同意入群
            Api_HandleGroupEvent (IRC_机器人QQ, #IRC_被邀请加入群, IRC_触发对象_主动, IRC_消息来源, IRC_原始信息, #IRC_请求处理_同意, “”)

        .如果真结束

编译好插件下载地址

乾坤-同意加好友源代码

总结

本教可以实现配置允许加机器人好友和允许拉机器人入群功能,代码如上

完整源代码售价 5元 http://u.720life.cn/s/1286a3c0

最新回复 (0)
    • 良心人论坛-专注免费软件开发
      2
          
返回
发新帖